Computer to TV display help

Viewing 9 posts - 1 through 9 (of 9 total)
  • Computer to TV display help
  • meeeee
    Member

    Trying to connect my PC to my tv but it’s not going as well as I thought.

    I’ve got display port and VGA on the pc, TV has hdmi and VGA inputs.

    If I use display port to hdmi then it works but I have to manually shrink the display so it doesn’t go off the edge of the screen. This works but often when Windows does updates and restarts it boots up with a blank screen and I have to unplug the displayport and plug it back in again for the image to come on the TV.

    Nevermind I thought, I’ll use VGA, that must work better. Well it works but instead of wide-screen on the TV the image is just square. I can adjust the TV to wide manually but then things look a bit stretched.

    What am I doing wrong, it’s 2019, surely it should be simple to plug a pc into a TV and it to scale the display automatically to the correct size!

    (Windows 10 and on board intel graphics, no separate graphics card)

    Premier Icon molgrips
    Subscriber

    I’ll use VGA, that must work better. Well it works but instead of wide-screen on the TV the image is just square.

    Adjust the resolution on Windows?

    Resizing the image is a TV thing – I had to do this on the Playstation. Not sure why it won’t detect the telly on restart – it should do.

    Tv will be set to OVERSCAN on the hdmi. Remove this, its a legacy of the old analogue transmissions. (probably)

    setting should be hidden somewhere in the settings. turning it off should get the display to correctly translate to a pixel 1:1 assuming the laptop is set to the native screen resolution.

    meeeee
    Member

    With VGA, i adjusted the display to the one that popped up as recommended on windows, but still not filling the screen.

    Have to double check when get back home. What should the aspect ratio menu be set as, think there were about 4 options on the intel graphics setting window. Maintain display scaling was one and a few others. Should have started this topic when I was at home with it in front of me!

    meeeee
    Member

    Not sure why it won’t detect the telly on restart – it should do.

    It does on a normal restart, just when Windows does certain updates and restarts there’s no display.

    In general is VGA better than display port to hdmi or do they produce the same quality image?

    I’ll check the Overscan thing as well.

    nickjb
    Member

    What am I doing wrong, it’s 2019, surely it should be simple to plug a pc into a TV and it to scale the display automatically to the correct size!

    Generally yes, it is pretty simple and it does just work, loads better than it used to. I suspect your kit is not from 2019 though. There was a bit of a messy period in the switch to HD and digital before things settled down.

    I’d find the right native VGA settings for the TV and force the PC to use those

    meeeee
    Member

    I suspect your kit is not from 2019 though

    Umm yeah your suspicion would be correct, TV is form about 2009!

    I’d find the right native VGA settings for the TV and force the PC to use those

    Is that the resolution that windows pops up as recommended, or something I find off the tv?

    meeeee
    Member

    Right scrap all the VGA stuff, I’ll have to stick with display port as I’ve just realised VGA doesn’t send audio, and I have no other speakers!

    So just need to work out why my display port doesn’t work after updates. Or probably simpler to reposition it so ican access the connectors easier to unplug and replug it after updates!

    Premier Icon Cougar
    Subscriber

    In general is VGA better than display port to hdmi

    Quite the opposite, by a long long way (and no audio as you’ve just said).

    Check overscan as suggested above, and that the TV is in ‘native’ mode.

    Are you mirroring the laptop display (ie, same image on both)? If so then both panels will need to be the same resolution, that could be causing a non-native resolution to be projected (though usually it’s the internal one that goes sideways when there’s a mismatch IME). Extend the desktop or disable the internal display instead.

    Win-P is the keyboard shortcut for “project,” might be useful.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.