Viewing 12 posts - 1 through 12 (of 12 total)
  • XTR 12 speed shifter, now 7 speed! confused
  • Premier Icon hutchweb
    Full Member

    My 18 month old XTR M9100 shifter coupled with XTR derailleur has suddenly switched to 7 speed, up and down the block.
    However if I disconnect the cable and just hold the cable to apply pressure it clicks up 11 and down 11 OK. Connect it backup to the derailleur with chain on or off it jumps up and down in 7 clicks! Covers the whole range of the cassette. No increase in shifter tension going up but the click down is feeling sticky when on the 51 tooth. Any one any ideas, it is seriously complex inside the shifter, white grease still looks good have added some more but made no difference. Will try and warranty it but just wanted to check I am not missing anything obvious.

    Premier Icon submarined
    Full Member

    My guess is it’s lost the end of the ratchet pawl, and it’s therefore grabbing several years at a time, and this only shows up under pressure.
    I hope not, as that’s a flashback to the 90s when Shimano shifters had a nasty habit of that!

    XTR is 3 year warranty, isn’t it? Stock may be an issue though.

    Premier Icon MartynS
    Full Member

    Did you change the cable just before it went 7 speed or did it just do it?

    If you have changed cables make sure it’s routed around the clamp correctly. I made this mistake, thought the mech was bent as I couldn’t get the gears to shift properly and it jumped a few cogs, so bought new mech!

    If it just happened then I’d guess it’s a failure, but the fact the shifter gives 11 clicks when disconnected is odd.

    Premier Icon hutchweb
    Full Member

    That makes sense. It has all worked flawlessly for 5.5k miles. I found SDJ has stock so have ordered a replacement. When I get the warranty replacement I don’t think I will have a problem selling it!

    Premier Icon hooli
    Free Member

    An outside chance and possibly a stupid suggestion but are you sure you have the cable anchored the correct way around on the rear mech? by this I mean the direction the cable enters the clamp on the mech.

    Routing it backwards changes the cable pull and this causes all sorts of strange things.

    Premier Icon exsee
    Free Member

    I had to warranty 2 XTR 9100 for the internal ratchet skipping gears.
    Mine were clearly skipping/engaging randomly though rather than any sort of pattern.

    Premier Icon Burchy1
    Free Member

    What Submarined outlined is what happened to my 11 speed XTR shifter. I’d guess it was an occurrence of that issue.

    Premier Icon P20
    Full Member

    Has the outer housing jumped out of cable stop or end cap?

    Premier Icon theflash
    Free Member

    Does it do the same thing with the rear mech clutch turned off? if not then the clutch has corroded and is sticking so needs cleaning

    Premier Icon hutchweb
    Full Member

    Thanks Hooli and MartynS, I did have the cable clamped the wrong side of the clamp! Back the correct way and it is working fine now!
    Never too old to learn, your an idiot.

    Premier Icon belugabob
    Free Member

    “you’re”
    😉

    Glad you sorted it

    Premier Icon hutchweb
    Full Member

    Now you are just twisting the knife.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.