Linux help needed – WPA wireless security

Home Forum Chat Forum Linux help needed – WPA wireless security

Viewing 8 posts - 1 through 8 (of 8 total)
  • Linux help needed – WPA wireless security
  • Premier Icon mikewsmith
    Subscriber

    For the best linux advice, structure your google well..
    after that Dell worked with Ubuntu on several things
    http://www.ubuntu.com/certification/hardware/201205-11048/
    the next model up looks certified with V12 which may be worth a go, you can put the mint desktop on top of Ubuntu if you don’t get on with Unity
    Not as much use for yours but there are some Ubuntu support stuff on Dell
    http://www.dell.com/support/troubleshooting/us/en/04/Product/precision-m4700 too.

    I would suggest trying a specific Mint forum for detailed advice searching with the Laptop model and wireless device details.

    Premier Icon cp
    Subscriber

    My rescued laptop (by baking the motherboard) is back to life – it’s a Dell Precision M4300. I’ve installed Linux Mint 15 and sorted out the Broadcom wireless driver. It sees my wifi network at home, which has WPA/WPA2 encryption. Even though the password is correct, it just wont connect and the pop up just keeps popping up asking for the password after a few seconds of if trying something.

    Googling suggests WPA/WPA2 is an extensive problem with Linux. Does anyone have any suggestions on how to get the chuffing thing working?

    I’m a Linux newbie, but very PC literate, and don’t mind getting my hands dirty.

    Ta 🙂

    samuri
    Member

    The first thing I’d try is temporarily turning encryption off. See if it will connect then. That way you’re confident that it is WPA that’s causing the issue.

    Personally, I don’t believe WPA is a problem with linux any more. I’ve built many linux devices over the last few years and they’ll all worked seamlessly with WPA for me. But then I am more inclined to run Ubuntu than mint.

    Premier Icon aracer
    Subscriber

    Try searching for “WPA supplicant” – that is an alternative way to get WPA running than the standard network manager. I’ve found it more reliable on the whole. You probably have to be comfortable with doing stuff in a text terminal rather than with a GUI though.

    dobo
    Member

    hmm never had an issue with WPA either, ubuntu and variants working here for years. as above disable encryption and see if that works and go from there. narrow down the googling

    chvck
    Member

    It could be the drivers that you’re using. On my personal laptop some drivers mean that the wifi connection drops out or that it won’t connect even though it can see the signal fine. That does have a wifi card that a lot of linux distro’s seem to struggle to even recognise though… That’s a dell studio 1555 and has a broadcom BCM4312 card.

    On my work laptop had no problems with WPA on several distro’s though.

    Premier Icon mikewsmith
    Subscriber

    forgot to say (having read the stuff from above) google the exact wifi chipset for more info.

    failing that off and on again or usb dongle – giving in, far quicker than working **** out

    blackburied
    Member

    The broadcom wireless card is a pita with Mint. You will find multiple guides with different solutions.

    You just need to work through them and find the one that works. IIRC I’m using the broadcom drivers from their website and not blocking in blacklist.conf.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Linux help needed – WPA wireless security’ is closed to new replies.