Mac/WiFi problems – doing my NUT in!

Home Forum Chat Forum Mac/WiFi problems – doing my NUT in!

Viewing 35 posts - 1 through 35 (of 35 total)
  • Mac/WiFi problems – doing my NUT in!
  • Premier Icon MussEd
    Subscriber

    Now I’m aware this will be music to the ears of a particular type of person, but I’m having all sorts of hassle with my Mac and linking to my WiFi network.

    The connection cuts out at random moments(seemingly choosing the most inopportune moment to do so, like when you’re finally ready to check out whilst shopping online), websites take an age to load and sometimes just crash altogether.

    The thing is, I have no problems with a tablet or phones on the same wifi network, only the iMac…I’m not talking when loads of wifi gadgets are operating at the same time, even when it’s only the Mac that’s being used these problems occur…

    What the deuce is going on? Bought this thing thinking it’d be fast flawless and fault free. It’s a massive pain in the tits to be honest. Is there something going on I should be aware of, or is it just a rubbish set up…

    Mackem
    Member

    Same with my MacBook.

    atlaz
    Member

    I have that with my Macbook Air but not my older white Macbook. No clue what the problem is so I just live with it. Sorry.

    Unplug it, leave it unplugged plug it back in 30 seconds later then turn in back one 30 sec after this resets the whachamajoggs. (For the Macbook pro take out the battery)

    Reset the PRAM silly thing but often works when for no apparent reason they start doing stupid things. Option Alt P R I think it is…hold them down at restart and keep them held down till you’ve heard the chime a few times.

    I’ve no idea if these will help, but to be honest I’m about sick of Mountain Lion and it’s glitches I’m got a Mac pro and twin Cinema screens Photoshop will lock out, cursors will vanish in InDesign from one screen to the other or just Buzz and flicker.

    I’ve not had one problem and I swore it ran faster in Snow Leopard (which I reckon was their best OS since back in the day)

    Premier Icon MussEd
    Subscriber

    Ah well, at least it’s not just me!

    damo2576
    Member

    Not had any problems myself – are you sure its not your router dhcp settings? Might be short lease time or something?
    Try setting mac on static ip

    Premier Icon Sandwich
    Subscriber

    Have you tried deleting your wifi network settings from the iMac and re-establishing the connection? Open network preferences, select wi-fi in the left column and then click the advanced button. Highlight your network on the preferred networks pane and then delete it with the “-” button. Then set it all up again.

    sharkbait
    Member

    Same here on our 2007 iMac. I’ve now gone to a wired network to save the hassle.

    samuri
    Member

    Are you all on the latest OS and patch level. There was a particular version that was absolutely awful for wireless.

    Plus then there was an Apple knowledge base article that explained how to make your connection more reliable. I did this and it worked immediately, one of the advanced settings.

    unfortunately I can’t find the knowledge base article and I’m not with my macbook at the moment.

    samuri
    Member

    I’ll be home soon maccy!

    dirtydog
    Member

    MussEd – Member
    Ah well, at least it’s not just me!

    Appears not

    26 page thread here

    https://discussions.apple.com/thread/2344256?start=0&tstart=0

    do any of you ever use google?

    I was having dropout problems – was fine for months and then suddenly got random (and fairly lengthy) dropouts. My MBP would get nothing while my wife’s MB and our iPhones were fine. Did my nut in.

    Turned out it was my router. O2 sent me a new version about 6 months earlier and for some reason it started to bugger about. Swapped it back to an older model and things were fine.

    mrmoofo
    Member

    Rather than automatically allowing to to select the network – go in and rename the one you have
    Then use that

    It is a common issue – go and search on apple sites for a walkthrough

    My new macbook doesnt do it. My IMac no longer does it since I chnaged ISP

    Premier Icon MussEd
    Subscriber

    do any of you ever use google?

    When I know I’ll get a better, quicker answer on here, no.

    STW better and quicker than Google – you can have that one Chipps & co!

    konabunny
    Member

    Same with our MacBook Air. And just this second my iPhone wifi connection died!

    enfht
    Member

    What you need is iWifi.

    jonk
    Member

    Mine did it all the time. I just set the mac to have a static IP address – use one higher up so other devices dont take it when they connect.

    eamonnface
    Member

    I tried every recommended solution to sort of the problem on my (very new) iMac.
    In the end i bought one of these http://www.tp-link.com/common/subject/powerline/TL-PA211/ and problems solved immediately.

    Premier Icon brassneck
    Subscriber

    Try reducing the MTU size on the wLAN adaptor – it’s usually set to 1500, standard Ethernet, but I found that reducing it to 1400 gave a more reliable connection and let https sites work again 🙂

    Seems to be something twixt router and Apple wifi chipsets, as the new router I got from my ISP for postage was fine out of the box on 1500 .. I swapped it out as there was no way to reduce MTU on the iPhone or iPad that I could find.

    mattrgee
    Member

    Same here on 2008 macbook pro. Used to love my mac, Snow Leopard was great, Mountain Lion just crawls….

    grantway
    Member

    Thought it was just using this site where it is so slow
    I go on other sites with blistering speed.

    I thought the problem lays with the pop ups you see on this site and
    Apple’s anti virus reading the information as a lot of guys using PC’s
    have had problems with the pop ups on this site recently.

    Other than that book up an appointment with an Apple Genius and let them sort it out.

    Premier Icon MussEd
    Subscriber

    Try reducing the MTU size on the wLAN adaptor – it’s usually set to 1500, standard Ethernet, but I found that reducing it to 1400 gave a more reliable connection and let https sites work again

    Even though I have No idea what any of this means, I think I’m going to try this technique…

    Premier Icon rickmeister
    Subscriber

    I’m with Tom tom the Pie Person, our two macbooks kept bumping each other off the network and having really intermittent connections hat just got worse. DCHP settings were all to pot and the whole lot was unstable. Worse than not working at all…

    The router was pretty old too. It then ground to a halt and we now have a new netgear one.

    All the problems solved, plus a network drive that was impossible to hook up despite some great help off here, plugged in and now works perectly…

    If your MussEd from Musselburgh, your welcome to pop round and have a look…

    sniff
    Member

    Had the same thing. Router was the issue. Set a static IP for it and you’ll be alright. As jonk says above us one up the top end of the range. Your other devices will be jumping on the current IP which is assigned and screwing up your iMac.

    had same issues – spend 1hr under the floor in me house lasts night, now all cabled up with cat 5 and 60meg broadband

    PeterPoddy
    Member

    I run an iMac, an iPad, and my iPhone all the time. The only problems I’ve had are ISP/Modem ones. A new modem from virgin sorted most of it. Currently got visitors and and and extra 2 iPhones on the network, no problem at all. 🙂

    The only recurring problem is iTunes loosing the connection and not syncing automatically. Restarting iTunes usually sorts it.

    samuri
    Member

    Found it now and it’s been mentioned above.
    What I did was delete the wireless points already known and manually added mine. Worked a treat after that.

    Apple crap. Every other device in the house, BANG, it’s on. The 1000 pound computer, nope.

    batfink
    Member

    I had this issue….. turned out to be the sh*tty free router that I got from Orange (netgear). To do with incomplete packets or somethin.

    Being a shameless fanboi I got a AEBS and now having no issue at all.

    Overpriced? Yes. But it solved the problem without having to spend hours learning what a dchp or an MTU is.

    samuri
    Member

    To do with incomplete packets or somethin.

    an MTU is.

    Sweet! You are a genius.

    batfink
    Member

    Sweet! You are a genius

    Thanks. I’ll tell my mum… she’ll be well-pleased.

    PeterPoddy
    Member

    Being a shameless fanboi I got a AEBS and now having no issue at all.

    Ahh yes. What’s one of those though?

    Jamie
    Member

    MBA + Virgin Superhub.

    Rock. Solid.

    Ahh yes. What’s one of those though?

    It’s an amusingly priced router from Apple:

    Airport Extreme Base Station.

    IA
    Member

    amusingly priced router

    Actually, it’s a good price for a 3×3 mimo wireless N router.

    Or with less tech-speak: It’s a good price for the current best quality wireless setup.

    Read the end of this:
    http://www.anandtech.com/show/4577/airport-extreme-5th-gen-and-time-capsule-4th-gen-review-faster-wifi-/9

    PeterPoddy
    Member

    It’s an amusingly priced router from Apple:

    Airport Extreme Base Station.

    Righto 🙂

    Or is it an Airport Express Base Station?
    Same initials!

    Premier Icon MussEd
    Subscriber

    Ok I’ve reduced the MTU size and all appears to be fine so far…

    Thanks Rickmeister for the offer!

Viewing 35 posts - 1 through 35 (of 35 total)

The topic ‘Mac/WiFi problems – doing my NUT in!’ is closed to new replies.