• This topic has 48 replies, 22 voices, and was last updated 1 day ago by walowiz.
Viewing 40 posts - 1 through 40 (of 49 total)
  • Posting images on Singletrack forum using Postimage
  • Premier Icon kayak23
    Full Member

    There are so many image posting fails on here, I thought I’d do a very quick pictorial guide about how I do it.

    It’s often put forward that everyone on here is an IT professional and so it’s surprising that so many struggle.

    There are lots of different ways of course, but this is what I do, and it’s incredibly simple to do, despite the claim of many who don’t quite manage it and get a bit mardy 😂

    Right then. The steps here are virtually the same whether on your phone, or computer.

    Essentially what we are doing is using an image hosting website (Postimage in this case) uploading our image to that, the site then gives us an ‘address’ for that image, we post it in the forum reply box using the specific button for images, and Bob’s your uncle.

    You don’t need to have an account to use Postimage. It’s free and simple. Many other sites are available that do the same but this is what I’ve come to use.

    Right, first open a new tab and go to postimage.org

    Notice the button at the bottom ‘Choose Images’

    This will allow you to navigate to the particular folder that your image/images are stored in. Choose the images and hit ‘next’ or whatever next looks like on your particular setup. You’ll get the image uploading screen.

    Once your image has uploaded, it will appear and it will say ‘Upload Completed’

    If the image does not have the little ‘Share’ icon by it (notice mine doesn’t here), just tap the image, it’ll appear in a new page with the little triangular dotted Share logo. Hit that.

    A pop-up box will appear with all sorts of sharing options. Hit the second one that says ‘Direct Link’.

    This will copy the image address that we want to your device’s clipboard.
    This should normally end in .jpg or sometimes .png

    Go back to Singletrack and to the reply box were you want to post your image. Hit the ‘img’ (image) button.

    You’ll get a box pop-up asking you to enter the ‘Url’ (address) of the image. This is the line of text ending in .jpg on your clipboard.

    Paste that into the box making sure that you are not including the text that is already there (http etc) as you already have that in the address you have copied to your clipboard, and including it twice will mess things up.

    It’ll look something like this after pasting.

    Hit OK. You’ll get a second box come up asking you to title your image. I don’t bother with this to be honest.

    Hit OK again and it’ll all appear in the reply box in a format that’ll become an image when you post it. You don’t get a preview unfortunately.

    When you’ve finished composing your reply, including the image related text, hit Submit.

    A picture of a dog on a paddleboard will appear, or indeed, whatever image it was that you uploaded.

    Hope that helps. It’s a better forum when people can post images I reckon. 👍

    No doubt many folks do this differently, but this is one way and it works fine.

    Premier Icon beej
    Full Member

    You’ll get a second box come up asking you to title your image. I don’t bother with this to be honest.

    This text is useful for people who have to use screen readers. A simple “a dog with a paddleboard” means they’ll get a description of the image.

    P.S. thanks for posting, I use the same method

    Premier Icon Drac
    Full Member

    You can just paste the direct link and STW will do the magic, you don’t need the IMG box.

    Thanks for writing this.

    Premier Icon grum
    Full Member

    I can do it, I just CBA most of the time especially when I’m on my phone. Some forums let you upload images direct to posts, imagine!

    Premier Icon ads678
    Full Member

    Alternativley hit the ‘hotlink for forums’ button and paste directly into the text box on STW.

    eg:

    Premier Icon kayak23
    Full Member

    You can just paste the direct link and STW will do the magic, you don’t need the IMG box.

    Thanks for writing this.

    No way! Every day man…. 👊

    Edit, actually I’m sure I used to do this and then one day it stopped working and would only work using the img button. Glad it’s working now.

    I always seemed to have to modify my steps slightly when on a PC for some reason, but the basic principle remains the same.

    Premier Icon scotroutes
    Full Member

    How come the magic anti-spam feature let you post so many images? Has it been switched off? @drac?

    Premier Icon Drac
    Full Member

    Not what I know of, but he’s not using Flickr which doubles the links.

    Premier Icon colin9
    Full Member

    is that your dog?

    Premier Icon walowiz
    Full Member

    @kayak23 great write up. I use Flickr and I rarely post images here, so can never remember which share option to use from within Flickr. I usually choose the wrong one.


    @grum

    I can do it, I just CBA most of the time especially when I’m on my phone. Some forums let you upload images direct to posts, imagine!

    ^this, just about every other forum I use allows you to upload images, simple and easy peasy. Doing it manually from Flickr etc on your phone is a complete faff, so I never do it on STW.

    Premier Icon Onzadog
    Free Member

    I don’t do it often and whenever I do, it fails. Still no idea what I was doing wrong at the weekend. Looks like a mod “fixed” it for me now, but I’ve no idea what that entailed.

    I don’t work in IT.

    I appreciate the effort of writing all that up, but I’m also pretty sure that’s what I was trying to do, with and without the /IMG bit.

    I might even be the “Mardy” one that was referenced.

    Premier Icon Jakester
    Free Member

    You can just paste the direct link and STW will do the magic, you don’t need the IMG box.

    Yeah, right…

    Premier Icon MoreCashThanDash
    Full Member

    Testing, testing

    Premier Icon MoreCashThanDash
    Full Member

    Damnit

    Premier Icon MoreCashThanDash
    Full Member

    Try again

    Premier Icon MoreCashThanDash
    Full Member

    Yay!

    Too many http I think first time around.

    Thanks for the reminder, just not something I do often enough to remember how to do it.

    Premier Icon scotroutes
    Full Member

    Ok. I was getting the same problem with postimage

    Premier Icon kayak23
    Full Member

    is that your dog?

    Yes. Harold.
    Amazingly good and keeps relatively still on the paddleboard. Only tried to drown me once when a swan came past 😂

    Mind you, the canoe is better for keeping him out of mischief 😉

    Premier Icon kayak23
    Full Member

    You can just paste the direct link and STW will do the magic, you don’t need the IMG box.

    Just tried that. Still didn’t work for me on mobile. Just appeared as a clickable link.
    Have to use the Img button.

    I use Flickr and I rarely post images here, so can never remember which share option to use from within Flickr.

    I’ve not used Flickr for a while as Postimage is so easy, but my approach on there was to hit share, copy the ‘BBcode’, and then paste that directly into the reply box without using the img button.
    Seemed to work.

    Premier Icon aide
    Full Member

    Test

    Premier Icon aide
    Full Member

    Ha ha! Braw! I thought you had to be a member of the dark arts in order to post a photo on here. Thanks kayak, now just have to remember all this

    EDIT: must remember to hit favourites button so I can go back to this next time

    Premier Icon Drac
    Full Member

    Ta da!

    Premier Icon ads678
    Full Member

    Does it make a difference if you’re using the fancy editor or not? I am and can paste directly into the reply box but kayak can’t and looks to be using the standard editor??….

    Premier Icon beamers
    Full Member

    You can just paste the direct link and STW will do the magic, you don’t need the IMG box.

    https://i.postimg.cc/s2xgz2Dd/20210905-082610.jpg

    Edit – Nope.

    Premier Icon scuttler
    Full Member

    https://vgy.me for me. Similar but when the upload completes it loads the various link options including the direct link needed for the IMG tag.

    Premier Icon Drac
    Full Member

    Does it make a difference if you’re using the fancy editor or not?

    Yeah could be it’s that. I have it enabled.

    Premier Icon kayak23
    Full Member

    What fancy editor?

    Premier Icon Nobeerinthefridge
    Free Member

    Can we post images from Google photos?.

    Another forum I’ve used recently allows image upload direct from your phone, takes a few clicks, done.

    Premier Icon Mark
    Full Member

    Fancy editor controls are here https://singletrackworld.com/account/preferences/

    Premier Icon ogri
    Full Member

    Premier Icon CountZero
    Full Member

    Flickr was always a sodding nightmare, I’ve been using Postimage for quite some time, and it works really well. I might try the direct hotlink selection at some point, if it cuts out a step or two then great.

    Premier Icon sl2000
    Full Member

    @Nobeerinthefridge

    Can we post images from Google photos?

    Yes – use https://www.labnol.org/embed/google/photos/ to generate the url

    Testing…
    bikes in wheat field

    Premier Icon lambchop
    Free Member

    Premier Icon lambchop
    Free Member

    It works! Most recent pic on phone⤴️

    Premier Icon Nobeerinthefridge
    Free Member

    sl2000 – applause sir!. 👏🏻

    Premier Icon Nobeerinthefridge
    Free Member

    Premier Icon Nobeerinthefridge
    Free Member

    Magic, works a treat!

    Premier Icon kayak23
    Full Member

    It works! Most recent pic on phone

    You take pictures of chemical gloves? 🤔

    Premier Icon lambchop
    Free Member

    I did as I needed to order some following an incident at work

    Premier Icon Onzadog
    Free Member

    Japanese knotweed

    Thought I’d see if it was any different with the fancy editor.

    Theres a picture there now after 5 attempts. More by luck than judgement. No idea what made the difference.

Viewing 40 posts - 1 through 40 (of 49 total)

You must be logged in to reply to this topic.