Wireless router question

Home Forum Chat Forum Wireless router question

Viewing 14 posts - 1 through 14 (of 14 total)
  • Wireless router question
  • Got a new D-Link wireless router….all working fine for internet access except I can’t login to it in order to manually change settings.

    I can get the login page up using a web browser but the default login details don’t work. I’ve done a factory reset and used admin/admin as suggested but in doesn’t recognise them. I set the thing up using the CD and changed the PW to “admin”. Still no luck.

    Any ideas?


    maybe try a blank password or another browser.

    Premier Icon somouk

    Try another browser and try checking with D-Link via their support system to make sure that the documented details are correct. They may have released a new firmware or similar with updated credentials.

    What model router is it?

    Premier Icon andytherocketeer

    admin for username, and blank password sounds familiar (binned my old d-link, so can’t verify).

    might need to make sure cookies are enabled too.

    Premier Icon Cougar

    You’re definitely on you router and not next door’s, yes? Ie, you switch it off, you can’t get to the login screen?

    Admin / blank is common for dLinks. Where are you getting admin / admin from? Have you RTFM / checked on stickers under the router?

    Try wired rather than wireless?

    it’s a dsl-2740R

    yes – i’m def connecting to the internet via my own router both via wifi and cable from a desk top
    sticker on the bottom of it says admin/admin for login deatils. I have also tried admin/[blank]
    There is a firmware update but I can’t install it as you need to login to the router to do this.
    I’ve put a request in to their support but not heard back yet.

    will try another browser when I get home tonight. Like I say, I can access the internet with it and the wireless is really good all around the house, just that i don’t like not being able to access it to change settings.

    One other interesting point: the previous router was always visible under “my network places”, but this is not the case with the new d-link, which is only visible sometimes. This has no baring on interrnet performance or ability to login to the router.

    Premier Icon scaredypants

    are you running noscript or something similar in your browser – I seem to remember that causing me some headscratching

    are you running noscript or something similar in your browser

    Sorry, I’m a bit of an IT nupmty…how would I find out if the above is the case. I’m using IE on XP.

    Premier Icon scaredypants

    I’m using IE

    Then I think you’re not using script blockers (they’re sort of anti-malware – bit of a PITA to be honest. You’d know if you had it as lots of sites wouldn’t work until you allowed java/flash to run on them)

    Premier Icon Cougar

    AV could be interfering too, potentially.

    Are you sure it’s “admin” and not “Admin”?

    I’ve tried Admin/admin/password in vaious combinations.

    Cheers for all the suggestions folks, will try all that tonight and report back.

    Following advice gratefully received, I can now access the router settings using the default UN and PW.

    Solution to the problem was to clear history, cookies and temp internet files from IE. The router will now let me login without problems.

    Thanks for your help!


    glad it worked.
    funny some people appreiate free advice here and yet others scorn if the correct answer isn’t the time frame of 30mins


Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Wireless router question’ is closed to new replies.