Noisy discs when setting off?

Home Forum Bike Forum Noisy discs when setting off?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Noisy discs when setting off?
  • TandemJeremy
    Member

    When you apply them or all the time?

    If its when you apply them its just cold brakes at a guess. Maybe a bit of moisture.

    If its all the time its not centred properly

    Premier Icon soulwood
    Subscriber

    Its when they are applied, and only for the first ten minutes or so of a ride. Its like bedding my pads in from new, except on every ride. Just seems odd that its doing it now after so long. The pads have plenty of life left on them too. I'm guessing they are dirty after a ride, but recently the fine weather hasn't made conditions that bad. Hmmm maybe I've just answered my own question, maybe its because they aren't getting ground with a fine paste of Peak district grit on each ride?

    Premier Icon soulwood
    Subscriber

    My SLX discs have recently began to squeal and wail for the first ten minutes of a ride, then seem to "bed in" and they are fine, until the next ride where they do it again. Its now a routine to drag my brakes downhill for the first part of the ride to wake them up. I have cleaned the disc and sanded the pads down, seemed to work the first time but it soon resorts to the noise. Any ideas? They are shimano resin pads, the brakes themselves are about 12 mths old and this is the first time they have done this kind of thing.

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Noisy discs when setting off?’ is closed to new replies.