long shot.. help… Tempus Seven central heating controller

Home Forum Chat Forum long shot.. help… Tempus Seven central heating controller

Viewing 10 posts - 1 through 10 (of 10 total)
  • long shot.. help… Tempus Seven central heating controller
  • i’ve got a tempus seven controller for the heating/hot water in my (rented) house.

    it seems to have stopped working – no matter what buttons i press, or where i slide the slider to, the read-out on the screen won’t change.

    we usually manualy control when the hot water/heating is on/off, but from what i can gather the read-out is now saying its on a 5/2 day program (on at 8am, off at 6.30am?!) but not showing the current time. it’s never been set up that way, and whatever i press, i can’t change it.

    i’m cold and covered in mud and need a shower, but there’s no hot water, and i can see my breath in my house. my spanish housemate is dying…

    i’ve tried to call the helpline, but conveniently they’re closed. has anyone got any idea what i can do???

    the tempus seven looks like this… but the display is showing bars under mon to fri, no time, and 8am, 6.30 at the bottom. there are no dots present on either left or right extremes (where we usually control it from).

    please help!


    Pull the fuse and start again 🙂

    do you think the fuse might be the problem? there’s a fuse thingy under the box which i could investigate. i figured that given there’s a display there, the fuse hadn’t gone?

    i’m freezing my tits off here 🙁

    or, do you mean just pull the fuse out to re-set it? this could be an idea… erm, silly question, but if i can access the fuse in the wall and just pull it out, will i die?


    Indo mean pull the fuse to reset it

    I am no heating engineer but if i had that issue and id tried all else id pull the fuse and put it back in and if that didnt work – call the land lord

    cool… so, just before i go an electrocute myself… looking at the fuse box, with all the switches in, there’s nothing about heating, but under the control unit there is what looks like a blanked off socet with a fuse under it – can i just reach in with my fingers and pull it out??

    the landlord is also currently dealing with a roof which leaks…


    Dont do that tom

    If its not marked well either throw the main breaker ala power cut or leave it alone.


    Email me a photo of what you see if you want

    i’ve done it!!!!!!!!!!!!! 😀

    thank **** for that.

    cheers terry!

    oops, just seen the rest… the fuse socket just came out with the fuse attached (i used a knife – just wanted to see what was under it), so i pushed it back in and the heating is now on.

    no power cut!

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘long shot.. help… Tempus Seven central heating controller’ is closed to new replies.