Viewing 18 posts - 1 through 18 (of 18 total)
  • IT help required pretty please
  • Premier Icon blader1611
    Free Member

    I am with virgin using a superhub 3 I am trying to add an old sky hub (SR201) to upstairs but i keep coming across a weird problem. I have turned DHCP off (on the old sky hub) and set it to 192.168.0.254 but everytime i turn it on it appears my sons Fire HD kindle cant access the internet even though he is connected to my virgin hub. Its only his device that is affected and all other devices regardless of which hub they are connected to works just fine. Should i be setting the old sky hub to an ip address outside of the dhcp scope of the virgin hub?

    Premier Icon FuzzyWuzzy
    Full Member

    What IP has the superhub 3 allocated to the Kindle?

    Premier Icon sharkbait
    Free Member

    Should i be setting the old sky hub to an ip address outside of the dhcp scope of the virgin hub?

    Yes absolutely.

    Premier Icon sadmadalan
    Full Member

    On the SH3, go into the advanced settings and change the range that DHCP uses to allocate addresses. On the SH3, it gives the starting address to allocate IP addresses (in my case 19.168.0.10) and the the number to add to this to give an upper address. Change this number to something like 190 and this means that the upper IP address is 192.168.0.200 which is less that than the Sky router.

    Restart any devices to make sure that they get IP addresses in the new range.

    After that you need to look at why the Kindle is trying to connect to the Sky router!

    Premier Icon Cougar
    Full Member

    Get the MAC address of the Sky router’s NIC. Add it as a DHCP reservation on the Virgin router so that it always gets given the same address. Set the interface on the Sky router to DHCP.

    Life’s too short to be cocking about with manually assigning static IP addresses.

    Premier Icon blader1611
    Free Member

    Cougar, wouldnt that mean both the virgin and sky hubs are dealing with dhcp which could end up with double NAT issues.
    I am making the changes you guys recommended as this is just utterly random and makes no sense and i have had enough trying to work out how this situation is even possible.

    Premier Icon blader1611
    Free Member

    This is insane and i am starting to think some weird witchcraft is going on. I did what Sadmadalan suggested and my scope is to .200 and the Sky router is set at .254. The Fire HD tablet i told to forget the network details of the AP and connected it to the virgin wifi (AP still switched on at this point but not connected to tablet), still no internet!!! Turned off the AP at the plug and 20s later the Fire HD has internet, how is this possible?! The AP should be irrelevant at this point yet until i power it off the damn tablet connects to virgin hub but has no internet. Its POSSESSED!

    Premier Icon Flaperon
    Free Member

    Try setting the DNS manually on the Fire tablet to “1.1.1.1”.

    Premier Icon blader1611
    Free Member

    This is starting to fascinate me now as it doesnt seem technically possible and i feel like i am witnessing a miracle.
    Today is a new day and i have fresh eyes and its as clear as mud what is happening. The FIRE HD is connected to virgin hub and has no record of the existence of my Sky AP. The Fire hd was connected to virgin hub but had no internet, tried turning wifi on/off on device several times but no luck. I go upstairs and power off the Sky AP even though it has no relation to the Fire tablet and boom his tablet has internet again. Could it be that the Sky AP router is giving of a frequency that affects only my sons tablet? It is doing something to it without ever being connected to it, this sounds crazy i know but trust me i keep witnessing it.

    Premier Icon Flaperon
    Free Member

    You see the post directly above where it says “change the DNS”. Well, change the DNS.

    What’s the point in anyone offering help if all you’re going to do is turn stuff off and on and then complain that it doesn’t work?

    Premier Icon blader1611
    Free Member

    Sorry Flaperon i hadnt seen your post but i will try it if i can stop long enough from just turning stuff on and off.

    DNS wont do anything as its pointing to the main router

    Premier Icon Flaperon
    Free Member

    Apologies. On re-reading my comment it does come across as both sarcastic and bitchy. 😕

    Premier Icon Greybeard
    Full Member

    To the Virgin hub, the Sky router/AP and the Fire are both just devices, and one device going offline when another joins points to an IP conflict. Maybe the Fire had cached an IP from before you change the DHCP range. Can you log in to the hub and see what each device is using?

    WiFi connection with no internet points to a DNS problem, as Flaperon says. But it might also perhaps be a symptom of receiving the WiFi signal but failing to connect because of an IP clash. Some small devices don’t have an option to set a specific DNS, they are set to pick it up from the router.

    Since I can’t work out the logic for the problem, maybe it’s just an incompatibility of settings somewhere. Is everything definitely on the same subnet, with the correct subnet mask, and the Sky AP pointing to the Virgin hub as gateway? Are you using the same SSID for both routers?

    Premier Icon FuzzyWuzzy
    Full Member

    What’s the default gateway the scope is issuing? It does sound like an odd problem and once the Sky hub is on the Internet-bound traffic is going to it rather than the Superhub 3 (if an IP conflict has been ruled out) so only explanation I can think of for that is the default gateway issued via the DHCP scope is .254

    Premier Icon Cougar
    Full Member

    The one thing that hasn’t changed throughout is the Sky IP. Change it from .254 to .253 or something.

    Cougar, wouldnt that mean both the virgin and sky hubs are dealing with dhcp which could end up with double NAT issues.

    Assigning the address manually on the Sky box or dynamically with a reserved address from the Virgin box shouldn’t make a fig of difference to anything, ultimately it’s still the same IP address. The only differences are a) you no longer have a static IP to keep track of, you have a reserved IP which is functionally the same but doesn’t run the risk of IP clashes because your DHCP server is aware of it, b) it stops you getting kicked off the interface if you have to change it and c) it dodges the possibility of you getting the other settings (subnet, default gateway, DNS etc) wrong as these are provided by the server rather than typed in by you.

    You get double NATting when you have a router behind another router. You shouldn’t have double NAT issues in this case because you have – presumably, and correct me if I’m wrong because it may well be important – connected it up via one of the Sky box’s switchports rather than the WAN interface. Ie, the Sky router isn’t a router, it’s a switch (and Wi-Fi bridge).

    Premier Icon Cougar
    Full Member

    Actually,

    Can you even set the Sky box to be a DHCP client or does it have to be hard-coded? It’s not something I ever tried.

    In any case, the way you’re doing it – with a static IP address within the same subnet but outside the DHCP scope – should still work. It’s more admin work is all, which is why I try to avoid it wherever possible. Years ago I worked in an office where every device had a manually entered static IP address and it was a bloody nightmare.

    Premier Icon blader1611
    Free Member

    Thank you everyone, i have a lot of suggestions to work through.
    Without double checking there wasnt an ip conflict when i checked connected devices but i will look again to make sure.
    GREYBEARD – the SKY AP has different ssid.
    COUGAR – I also worked in an office where they put manual static ip addresses in and it was hell. It was worse because they did that as a solution to a problem that didnt exist, most infuriating.

    Just checked and Fire tablet has ip address of .35 and no conflict.

    Premier Icon FuzzyWuzzy
    Full Member

    Just checked and Fire tablet has ip address of .35 and no conflict.

    What’s it’s default gateway?

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.