– No hot water!

Home Forum Chat Forum – No hot water!

Viewing 10 posts - 1 through 10 (of 10 total)
  • – No hot water!
  • OK so it turns out this is a combi boiler with 2 immersion heaters. Apparently the boost button is used when there is no cheap electricity rate available so uses the standard rate?

    Premier Icon wwaswas

    there’s def two heaters there – are they both not working?

    My guess is the thermostat on the heater with the timer has broken.

    You seem to have two separate heaters and two separate controllers. One with a timer and one without.

    Does the heater without the timer work ok, as in does the water get hot?

    The box on the left is definately not working, i assumed the other one wasn’t but since there’s 240V going through I guess this one still works. I will turn it on when i get home and see if I can get hot water.

    Are both the red things thermostats or is one some sort of protection with the reset button on it?

    Can anybody help, noticed that the immersion heater is not heating the water anymore. There are two separate boxes, one to set up timer programmes for the hot water to come on, another that has a boost button for extra heating i guess.

    The wires come from each box and there are two thermostat’s.

    I checked resistance on both which were fine (around 20ohms), I believe this means that the element is fine?
    I then turned the power on and checked voltage on both, one read 240V the other read 0.

    So does this mean the thermostat that reads nothing needs replacing?

    In the pics below you can see the thermostat, but there is a similar ‘thing’ next to it that I’m not sure what it is? Can anyone tell me? Both the thermostat and the ‘thing’ have rods poking into the tank. Where should i go from here? As you can tell I’m certainly no expert, i have just been following advice on what to check up until now.

    Any help appreciated, i have just been manning up and having cold showers but the girlfriend is starting to nag 🙄



    Pressed boost on both units last night but still no hot water at all 🙁

    Still having trouble with this, can anyone identify the parts?

    I know the red box with the dial on is the thermostat but whats the similar looking red thing next to it? Is this the element or is that separate altogether?

    Premier Icon bennn

    The first red unit, with a ‘rod’ (phial) into the water jacket is the overheat thermostat, with a resettable cut-out on it somewhere. The second in series is the control thermostat, with which you set the temperature of the hot water delivered at the tap.

    Are you saying you’re getting voltage down to the first thermostat, out of it into the second, but nothing out to the element?

    The element will be below both of these thermostats and you will just see two poles protruding from the brass of the immersion heater itself.

    Hope this helps,

    Premier Icon Smudger666

    Can’t help if it is one of the boxes that has gone, but the stats with the stickers on are the overheat stat – the black button at the ‘point’ next to the sticker might have tripped – try pressing it. If you hear a definite click, then it might have tripped.


    Thanks for that, yes im getting voltage on one of the elements, but on the other element there is no voltage going through the overheat thermostat. The other thermostat seems to be fed off the first.

    Had both heaters on last night and there was some hot(ish) water but still not as much as we had before. I think one element is working but the other isn’t.

    If the resistance through the thermostat live/neutral is normal (18 ohms) does that indicate that the element is working, but the thermostat is faulty? Would you replace both the overheat and control thermostat on this element?

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘ – No hot water!’ is closed to new replies.