Hope Vision One – anyone else had this problem?

Home Forum Bike Forum Hope Vision One – anyone else had this problem?

Viewing 7 posts - 1 through 7 (of 7 total)
  • Hope Vision One – anyone else had this problem?
  • Marge
    Member

    mine did this last night too….
    Was fine when I put it away for the summer.
    I just assumed (and hoped) it was that I had almost dead batteries…

    Midnighthour
    Member

    Had a similar (but possibly not the same) problem with the 2 visions 1's in the household. They switch off as soon as battery is low (terrible design fault for an otherwise good product)so will just come on then cut right out again. I found that if you leave batteries in the unit, they run down very fast. Best way to cure it is to take the battery holder out at the end of each ride as they seem to hold thier charge if not in the light. Something in the lights seem to drain them quite fast if left for any period of time just switched off. Its very annoying.

    Premier Icon Alex
    Subscriber

    Before I call Hope, my Vision 1 has developed a fault where when turned on, it flashes once and then dies. Switch seems to be working, tried two sets of batteries.

    Assume something has gone pop in the electronics, but wondered if anyone had seen anything similar. Ta.

    Premier Icon Alex
    Subscriber

    Ta. THat's interesting as I thought the spare set of batteries I installed were new. But I'll check tonight with a box fresh set.

    Same as Marge, first time I came to use it for commuting after "summer". Will check it next time 😉

    Midnighthour
    Member

    I used quality high power rechargeables that were bought for the vison 1's and they drained both sets of those 'switched off' with no problem at all. They were only storned in the lights around 2 days from a fresh full charge.

    Other than the draining and the dangerous shut off, the lights are very well designed. I hope they update them at some point to go down to a safety light level when power is low. I can survive the battery drain now I know to take the holder out, even though its a bit of a pain.

    Vinte
    Member

    I've just got one of these. It ran for close to 3 hours on full before the batteries died. I was using good quality rechargeables. Very impressive. Thanks for the tip about not storing the batteries inside the lamp.

    nickegg
    Member

    Mine wouldn't turn on straight out of the box with brand new batteries in it. I sent it back and they replaced whatever didn't work…the switch??

    I have left it for months on end (Haven't used it regularly since December when i no longer had a job to commute too!!) and it hasn't drained the batteries in it so seems strange that others have had this problem. The batteries in it haven't been charged since December!

    Oh…and that business of not shutting down to a low level is **** scary when tanking it down a pitch black country lane!!!!!!!!!

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Hope Vision One – anyone else had this problem?’ is closed to new replies.