Viewing 9 posts - 1 through 9 (of 9 total)
  • Hope Pro2, missing a seal? seizing up :(
  • foureyes
    Free Member

    Hi all, a new wheel, well, about 3 months old and its already rough and stiff to turn the axle by hand. Ive never had this with a Hope hub before. Noticed just now as i had it out to check if it had worsened that the end of the hub looks like it’s missing a seal.

    Cant be sure, and its not that clear here, but im pretty sure a pro2 usually has something filling these areas?

    its an evo pro2 if that makes any difference. cheers!

    crashtestmonkey
    Free Member

    have Pro2s not Evos but looks like the end cap is wrong, every one Ive got regardless of axle standard the end cap has a cover which seals against the hub body over/against the rubber seal you can see.

    Onzadog
    Free Member

    Nope, that’s normal.

    Anthony
    Free Member

    That’s the new EVO design!

    The driveside is also now without ‘flange’ and everytime I take my cassette off there is a good few mls of water sat in there, even though my bike sits next to a radiator when not in use.

    It’s perhaps as well they are now fitted with stainless bearings.

    Can’t quite understand it personally and the old pro2 bearing drifts don’t fit now either!

    foureyes
    Free Member

    Hmm, well i suppose i should ask Hope what comes next then, its rough and not free running at all now. Had nothing but goodness from Pro2 for years and years so its a odd-un

    oxym0r0n
    Full Member

    Can’t quite understand it personally and the old pro2 bearing drifts don’t fit now either!

    +1

    Had loads of problems with evo at the start – but has been working fine for a month or so… lets see how it fares over the winter 🙄

    tomcanbefound
    Free Member

    Had exact same problem on 2 new builds on pro2 evo’s sent back to hope and they replaced the bearings and had them back to me the same week! Now they run fine… Probably a bad batch of bearings made it through QC v0v

    carlphillips
    Free Member

    pro 2 …

    worst

    hub

    ever

    mine is made from cheese it would seem, constantly relacing pawl springs and the freehub is deffo made from cheese…once had one rear bearing fail which destroyed the hub & axle and pretty much and left me riding the nutcracker on a fixie! not great…my burgtecs however have been faultless..

    wish i had never bought mine…

    foureyes
    Free Member

    I’ve had loads and never ever had an issue even with my wheel building skillz. Have emailed hope

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Hope Pro2, missing a seal? seizing up :(’ is closed to new replies.

Thanks for popping by - why not stay a while?IT'S FREE

Sign up as a Singletrack Member and you can leave comments on stories, use the classified ads, and post in our forums, do quizzes and more.

Join us, join in, it’s free, and fun.