Hope C2 woes

Home Forum Bike Forum Hope C2 woes

Viewing 5 posts - 1 through 5 (of 5 total)
  • Hope C2 woes
  • richardk
    Member

    You're all reading the Countdown girl thread aren't you 🙁

    hamishthecat
    Member

    Could be a few things – probably need bleeding but it might also be a seal in the lever piston. Bleed it then see what it's like.

    I'm not a fan of the shiny dress… 😉

    coatesy
    Member

    Could be the adjuster/seal in the reservoir top cap not pressurising the system properly, either due to a leak, or the adjuster screw(LH threaded)becoming disconnected from it's piston.The correct operation of these depends on there being no air whatsoever in the system, and then the topcap adjuster pressurising the fluid to effectively take up the slack. If you're down on fluid for some reason then the lever stroke alone isn't enough to get proper braking action.

    richardk
    Member

    First ride in a while, and shame on me for not checking, but the lever on my C2s touched the bar first time I braked tonight. Luckily the back one worked so I'm not an accident statistic.

    Lots of travel in lever, but not no braking. I can see the pads moving when I take the wheel out, they just don't move enough. Adjuster on the levers has no effect.

    What's the problem and how do I fix it?

    clubber
    Member

    Most likely air in it. Clean it up, pull hard and see if there are obvious leaks but if
    not then just bleed them.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Hope C2 woes’ is closed to new replies.