Viewing 13 posts - 1 through 13 (of 13 total)
  • Garmin Touring help needed please.
  • houndlegs
    Member

    Evening everyone
    Further to my enquiry about buying a Garmin eTrex, I want to see if I can sort out my Touring rather than spend needlessly. I know I can send it for repair but I’d like to try to fix it first if I can.
    First of all, everything works as it should apart from the navigational side of things; speed,time,distance etc all work fine.It also records fine and downloads my data when I get home. I can also upload a route and its in there as it should be; summary,map,elevation etc all fine.
    Here’s the problem; when I want to follow a route,( lets say I’ve started the route a half mile from my house ) I call the route up, press ride, and it ask’s me if I want to navigate to start of route,if I press yes it gives me half hearted directions to the start of the route, then when I get to the start its as if it doesnt recognise I’m at the start, and does nothing, if I carry on with my ride, it just does nothing at all apart from leaving the last directions to the start of the route on the screen. If I call the map screen up, the route is there in pink, it just wont give me turn by turn instructions, there’s also no big white directional arrows, just the pink route. If I leave it running and complete the route, it tells me the route is finished. It just wont direct me.
    If when asked do I want to navigate to start of route I say no, its as if it takes that as I dont want to navigate at all, and just wont load the route.

    This happens on software versions 2.8 and 2.9, if I roll it back to 2.7 it works fine(apart from the glitches 2.8 and 2.9 were supposed to cure). Factory reset makes no difference at all.

    I know this is a long shot, but if anyone has any ideas, I’d appreciate it.

    Thanks.

    smurfly13
    Member

    Don’t have a touring – I have an Edge 800 but thought i’d throw some ideas out here.

    Each course on the 800 you have to turn on “turn by turn nav” – by default it is switched off for each individual course – its its set up screen with colour etc.

    Sounds like this could be the case if you are getting nav to the start and when you get there it just stops?

    If you click navigate to the start no you say it doesn’t nav at all – is the route still loaded and displayed on the screen, it just says nothing?

    houndlegs
    Member

    I’m not sure what “turn by turn nav”is, theres nothing in the Touring like that, that you can turn on/off.
    As for your last question, yes, I get to start of route then nothing, its still displayed, still showing the pink route line, just no directions.

    smurfly13
    Member

    Just looked, in the settings it’s called turn guidance on the 800, that needs seeing to on for navigation arrows

    Premier Icon molgrips
    Subscriber

    Hmm I have only just got one of these. It has done this to me before, but I can’t remember exactly the circumstances. I think maybe I was on a route following turn by turn, but then I had to abort and selected the ‘take me home’ option and it found the route but the arrows and warnings were gone.

    Premier Icon crazy-legs
    Subscriber

    They’re not really the most intuitive bits of kit ever, they do have a few little foibles and it can take some time to work them out properly. They need much longer then you think to settle down, work out where they are and realise you want to navigate a course.

    They’ll find satellites in no time at all but you need to give it a few minutes, sometimes try re-loading the course for it to realise.

    houndlegs
    Member

    ^^I’ve had the thing 2 years(ish) now,this isnt how its always been, just how its been lately. Its actually worked properly using 2.8 and 2.9 software up until recently, it’s just gone wrong for some reason. As if something has gone amiss in the actual internal workings of the thing.

    Premier Icon imnotverygood
    Subscriber

    Garmins often seem to do this. My Edge does not seem to give turn by turn dependent on the software used to create the route. There is fair bit out there on t’internet telling you how to make sure the route is acceptable to the unit, but it all gets a bit complex for the likes of me.

    Dibbs
    Member

    I would have suggested try the Garmin forums, but you already have.
    I seem to remember that one of the Edge 810 firmwares turned off Turn By Turn guidance by default where it had always been on, maybe they’ve done something similar with the Touring.

    Bruce
    Member

    I have an edge 200 and it does exactly the same the same as your garmin.
    I never got to the bottom of the problem and tried all the things that you did. As the 200 is cheaper I just lost interest in it and gave up using the thing.

    Premier Icon tillydog
    Subscriber

    Are you trying to follow a circular route? (i.e. start and finish at the same place?) If so, the Garmin will think that it has finished before it has even started. I believe that splitting circular routes into two parts is the recommended solution.

    Also, are you creating a Route, a Course, or a Track?

    Some info here (but you’ve probably already come across it).

    Flaperon
    Member

    Garmin navigation is temperamental at best, shit at worst.

    Some tips – make sure turn-by-turn guidance is on. Courses -> little menu button at the bottom right corner -> Turn by turn (or similar).

    Don’t use “navigate to start”. You can pick up a route that has “out and back” bits but you obviously need to be pointing in the right direction on the outbound bit.

    When you ask for navigation, it will take time (upwards of several minutes) to calculate the full route. Don’t move during this time.

    The “route finder” function is utterly useless, and probably a justifiable reason to return it if you’re sceptical about keeping it as not fit for purpose.

    Premier Icon crazy-legs
    Subscriber

    My Touring today started off doing full turn-by-turn but then sort of randomly stopped at some point. I hate trying to fix it mid-ride for fear of losing everything it’s saved so far (which happened once early on). Trying to get it to restart navigation midway through a ride can sometimes work but equally it can get very confused and start trying to guide you to the beginning of the ride rather than being able to work out you’re half way along it and want to continue.

    Really not intuitive. For a while I resorted to carrying my old 500 as a backup so I’d still have the ride saved.

    When you ask for navigation, it will take time (upwards of several minutes) to calculate the full route. Don’t move during this time.

    ^^ this. It will show satellite acquisition almost immediately but then it can take several minutes to work out routing, especially on off-road sections.

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Garmin Touring help needed please.’ is closed to new replies.