Exposure lights – first charge out of the box

Viewing 7 posts - 1 through 7 (of 7 total)
  • Exposure lights – first charge out of the box
  • Premier Icon Trailrider Jim
    Subscriber

    I put my new Maxx D on charge using the mains smart charger and the display is flashing with the percentage going down from 75%. The LED on the charger is green. This is contrary to the instructions, which say “the LED on the charger will go red for the first 95% and then go green for the trickle charge.

    When I first plugged the charger in, the light switched on, so I held down the steel button to switch it off whilst charging. Should the charge be going down?

    Premier Icon paul_m
    Subscriber

    That doesn’t sound right to me, on all of my lights the charger goes red when I plug a light in. Do you know someone else locally who has an Exposure light that you could try a second charger with. I would also speak to thh folk at Exposure, the Customer Service is great.

    scotroutes
    Member

    Doesn’t sound right.

    Disconnect everything.

    Make sure the torch is switched off.

    Plug  charger into mains.

    Switch on charger.

    Connect charger to torch.

    Charge should be counting up.

    Premier Icon Trailrider Jim
    Subscriber

    Thanks. Followed the above steps but it’s still charging down. Disconnected and now calling Exposure.

    Premier Icon reluctantjumper
    Subscriber

    Have you inadvertently put it on the mode that powers accessories? My Equinox wouldn’t charge until I switched that back off, had to switch the light on, go through the power settings then switch off and all was fine again.

    Premier Icon Trailrider Jim
    Subscriber

    After a quick call to Exposure, they’ve confirmed they’ve had reports of faulty chargers going out recently. They’re sending me a replacement one. It’s now charging fine from the supplied USB lead.

    Premier Icon mccraque
    Subscriber

    Just be aware that the USB lead doesn’t give you the full charge that the plug does!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.