• This topic has 35 replies, 19 voices, and was last updated 4 years ago by nixie.
Viewing 36 posts - 1 through 36 (of 36 total)
  • Exposure – how customer service should be
  • Premier Icon mrblobby
    Free Member

    Problem with the remote switch on my Strada light. Emailed them yesterday with a photo. New one arrived in the post today. Great work 🙂

    Premier Icon PolisherMan
    Full Member

    That’s exactly the sort of thing I like to here.!

    Having just bolted my brand new maxx d to my bars. Pay proper money and (hope) to get proper service… 😉

    Premier Icon Gary_M
    Free Member

    I dropped my strada on the concrete floor in the bike shed last year, light then wouldn’t work. Contacted exposure to explain what happened, the said send it back, they repaired free of charge, battery came lose, and didn’t charge for return postage.

    Remote switch also stopped working, replacemnt delivered the next day.

    Great products and a after sales great service.

    Premier Icon trail_rat
    Free Member

    Oh yes. I love the guys at exposure.

    No bullshit.

    Treat the. With respect tell the truth and they will do their darndest to get you going again without it costing an arm and leg.

    They also support UK racing which is a big plus for me.dont see 7dayshop /ebay doing that

    Premier Icon joshvegas
    Free Member

    My revo came back with a note.

    “We fixed it dont put the output from the hub into the outputof thelight again.”

    Premier Icon mrblobby
    Free Member

    “We fixed it dont put the output from the hub into the outputof thelight again.”

    😆

    Premier Icon whitestone
    Free Member

    “We fixed it dont put the output from the hub into the output of the light again.”

    I’ve heard of one or two people doing that (not me, I don’t have one), a slight design flaw methinks. Yes it’s user error but shouldn’t be possible. A smaller socket on the output port would prevent it.

    I’ve a Joystick and am very happy with it – the above is just about the Revo not a dig at Exposure 😉

    Premier Icon trail_rat
    Free Member

    But render the output no use for any existing red eyes ..

    Premier Icon orena45
    Full Member

    Ah, interesting to hear about the remote’s being replaced quickly and easily.

    Are these older lights so you’ve gone direct to Exposure rather than lights still under warranty where you normally need to go back to the place of purchase? Bought a Strada 1000 a couple of months ago and the remote has stopped working recently but was going to wait til the spring time as I presume I’d need to send the whole unit back to the shop for them to sort, so would be without a light for a week or two.

    Premier Icon whitestone
    Free Member

    But render the output no use for any existing red eyes

    Good point. Just ship a very short converter lead – yes it’s another connection and a bit of extra cost – but the visual clue of the lead in the back of the unit would reduce user error (I’d hope!)

    Premier Icon mrblobby
    Free Member

    orena45, in my case the rubber button part of the remote had fallen out somehow so not just a case of stopped working. I just emailed Exposure directly with proof of purchase and a photo.

    Premier Icon trail_rat
    Free Member

    Oh I’m with you Whitestone. Could also make the input connector bigger so it won’t fit in the other

    But itseems exposures AVE decided the revos a non viable product line and won’t be developing it further which is a shame said have like to have seen a road beam strada style version

    Premier Icon Gary_M
    Free Member

    Are these older lights so you’ve gone direct to Exposure rather than lights still under warranty where you normally need to go back to the place of purchase?

    I bought mine in October 2016, remote went a bit temperamental in December ’16 so I just emailed exposure and they sent me a new one.

    Premier Icon whitestone
    Free Member

    It’s a niche product I’ll give you that. I notice neither CRC or Evans now list it and while Wiggle list it all options are out of stock. Beginning to look like Klite is the only show in town regarding off-road dynamo lights.

    Premier Icon hedley
    Free Member

    Another +1 for their customer service.

    Also a +1 for their build quality. My joystick went through a full wash and 1200 spin (had left it in my bag) and it came out working fine and has ever since.

    Was impressed as it had fallen out of the bag so was rattling around in the drum as well.

    Premier Icon Splash-man
    Free Member

    Was impressed as it had fallen out of the bag so was rattling around in the drum as well.

    Please do not try this at homes kids……..

    Premier Icon nixie
    Full Member

    Hmm maybe I should get in touch with them about the laughable run time of my new Diablo and the useless tap feature. One hour on max, I don’t think so! Getting low battery warnings around the hour mark despite using a mix of high for down and low for everything else. The tap feature sounds great but in practise the light never stays on the mode I want, normal changes several times per downhill run!

    // rant over

    Premier Icon jkomo
    Full Member

    I emailed them to say my link had come off the helmet mount on a commute and been lost.
    I explained I wasn’t expecting them to do anything but to let them know in case there was a problematic mount design or something.
    Anyway they didn’t reply even to say tough shit.

    Premier Icon onewheelgood
    Free Member

    The tap feature sounds great but in practise the light never stays on the mode I want, normal changes several times per downhill run!

    You did read the bit in the manual where it says only use TAP mode if the light is helmet mounted, yes?

    Premier Icon tuskaloosa
    Free Member

    Hmm maybe I should get in touch with them about the laughable run time of my new Diablo and the useless tap feature. One hour on max, I don’t think so!

    So it’s not just me then… I called Evans about it they said to send it in. Still to do it, but I’m confident that Exposure will sort it out

    Premier Icon 13thfloormonk
    Free Member

    another +1, can’t actually remember what I sent my old Joystick back for, but it was probably something to with it sitting and gathering dust in a box for a year or two.

    Either way they fixed it, cheap, and got it back to me pronto.

    Might sound counter-intuitive but I think it’s good to be able to get stuff fixed rather than just replaced f.o.c, seems less wasteful that way.

    Premier Icon nixie
    Full Member

    You did read the bit in the manual where it says only use TAP mode if the light is helmet mounted, yes?

    Yeap. It is helmet mounted and also on the less sensitive setting.

    So it’s not just me then… I called Evans about it they said to send it in.

    Mine also came from Evans. Wonder if there has been a bad battery batch. I’ve been meaning to do a static runtime test of full to double check I’m not imagining things.

    It’s a shame as if feels really nicely out together, just doesn’t quite meet expectations.

    Premier Icon onewheelgood
    Free Member

    Yeap. It is helmet mounted and also on the less sensitive setting.

    Fair enough. I disabled Tap on mine too. I won my Diablo in a comp, so can’t really complain. I did buy a support cell so that I could use it at Mayhem – no way the standard battery would have lasted long enough.

    Premier Icon nixie
    Full Member

    I’m going to contact them directly to see if it is possible for it to be reprogrammed to be even less sensitive. I have wondered if is the weight causing it to bounce on the helmet. Don’t want to have to do it but was considering a remote on the helmet as the button in the back is way too small.

    Premier Icon Flaperon
    Free Member

    Mine also came from Evans. Wonder if there has been a bad battery batch.

    Hmm… and mine. Went back once because the battery drained while it was off and a single tap of the power button would turn it on. Think they replaced the board but not the switch or battery. It’s doing it again now but out of warranty.

    I think they had a phase where emails were missed as I had a couple ignored. Tried again six months later and prompt and helpful replies.

    Premier Icon epo-aholic
    Free Member

    Yeah the guys are very very good, support me as a retailer very well too.

    Premier Icon trail_rat
    Free Member

    Ive bought 2 use lights from exposure. Both DOA.

    Everything I bought direct works fine.

    Won’t bother with Evans again.

    Premier Icon dove1
    Full Member

    Mine also came from Evans. Wonder if there has been a bad battery batch. I’ve been meaning to do a static runtime test of full to double check I’m not imagining things.

    I did a static test on my Mk8 Diablo last night after reading this thread.
    On the highest power setting it lasted 1hr, 26mins. Stated run time is 1hr.
    After about 55mins the indicator stopped flashing red and went off but the light stayed on for another half an hour.

    Premier Icon joshvegas
    Free Member

    a slight design flaw methinks

    Its a complete design flaw. Something you use in the dark that has two identical ports one in one out. Plan involving glow in the dark paint to be actioned.

    Premier Icon whitestone
    Free Member

    @joshvegas – I was being slightly sarcastic 😉 Yes, properly odd: Conversation at the design stage – “Surely no idiot is going to connect an input voltage to the output?”, “I wouldn’t have thought so, order double the number of those connectors”.

    Never overestimate customers 😆

    Premier Icon joshvegas
    Free Member

    Its compounded by the fact it sits above the bar sometimes and upside down under thebar depending on bike.

    Which ofcourse switch which port is in which location.

    😆

    Other than that though i likeit alot.

    Premier Icon nixie
    Full Member

    Just (finally) run time tested my diablo Mk9. Got low bat warning flash at 38 minutes and light off at 55 minutes on full. Not great!

    Premier Icon trail_rat
    Free Member

    Those of you doing static tests…. You are aware they need air flow to stay cool.

    They get incredibly hot if they don’t get airflow.

    This shortens run time considerably

    Premier Icon dmorts
    Full Member

    They’ve just sorted me a new charger for my Joystick, arrived next day

    Premier Icon ernie
    Free Member

    And on the flip side i had a custom etched USE stem that developed a wierd lump i.e. an area about 3mm bulged and split. I returned the stem and it was blamed on wrong bike cleaner. I work for network rail and have ready acces to many chartered engineers who called bs. USE refused to budge and even asked if i wanted to buy another off them.

    Premier Icon nixie
    Full Member

    Those of you doing static tests…. You are aware they need air flow to stay cool.

    Yeap, had a fan pointing at it for cooling.

Viewing 36 posts - 1 through 36 (of 36 total)

The topic ‘Exposure – how customer service should be’ is closed to new replies.

Thanks for popping by - why not stay a while?IT'S FREE

Sign up as a Singletrack Member and you can leave comments on stories, use the classified ads, and post in our forums, do quizzes and more.

Join us, join in, it’s free, and fun.