edge 705 – have i "bricked" it??

Home Forum Bike Forum edge 705 – have i "bricked" it??

Viewing 13 posts - 1 through 13 (of 13 total)
  • edge 705 – have i "bricked" it??
  • v12jat

    i have a few year old edge 705, that has worked great up until a particularly wet ride on Wednesday night!

    Basically, whilst it was plugged in downloading the data,it kept flashing up with “external power lost”.. this stopped after a while once i had unplugged it.
    then the charge screen/connected to computer screen is permanently displayed, and the device wont power on or off properly, sometimes it looks as if its going to start, but then it reverts back to one of these screens!
    When i plug it into the pc, you can still open the folders etc in windows, but the unit still displays these screens!
    i have tried both methods of reset, and again it looks like its going to reset, but the charge screen comes back on and stops the process!

    I let the battery drain too, then re charged and its doing the same thing!

    also updated software on garmin connect, this worked ok according to the pc, but the units still doing the same thing!

    Quite annoying!!!

    Anyone experienced similar, or is the unit completely fooked!?

    help appreciated!

    Premier Icon sandwicheater

    Do you have a warm place you can leave it for a few days? Worked with our GPS & camera when they were soaked.


    Put in a sealed container with rice, cross fingers for a day or two. Hopefully it’ll dry out. Best option would be to take the battery out and leave the whole thing in a container of rice to dry out.


    do u reckon water ingress would be the main issue here???


    I’ve left mine on a radiator on top of a few layers of t-shirts so that it’s warm rather than hot. SD card cover off, USB port cover off and leave it like that for a day or so to dry out. Did the job.

    Water getting in can certainly make it behave oddly though IME you can usually tell it’s got wet as the screen gets misty from inside.

    Premier Icon alibongo001

    OP if it is water damage (and it appears so)

    See if you can find some of the little packets of silica gel that you get in shoes / electrical equipment.

    Find as many as you can of these and put the Garmin in a sealed sandwich bag with them in a warm or sunny place. 3 days later it will be as dry as it is going to get.

    Silica gel is much better than rice for this if you can find it (they sell it on Ebay too if you can’t find any)


    Might just be dodgy connection on the SD card due to water. Take it out and see if it boots up?

    Otherwise leave to dry.

    Pretty easy to open up if you want to take the battery out too (think its recommended until its completely dry).

    Premier Icon ricardo666

    My 705 decided to freeze on me last year, its was second hand from the forum. And used the opensource maps.

    Anyways I used a torx driver think it was a T4 to open the case.

    Unplugged the Usb socket and took the battery out, and left it disconnected for the rest of the afternoon.

    Put it all back together, and it came back to life.

    Not sure what had caused it to freeze, reloaded the latest version of the maps on, and its been working fine so far.


    cheers for the help! its currently on a radiator hopefully drying out properly!


    If all else fails return to Garmin, there after-sales is brilliant in my experience, even on older models.


    Loving how these garmin outdoor bike units are not very waterproof!! I am convinced it was water that trashed my old edge 500.


    right, i have left it to dry out, the battery has drained, i’ve even disconnected it. it powers on, but its like its permanently plugged in, so the charge/usb screen never goes off, and when in menu mode,the little plug is showing as if its plugged in!

    could the socket have got damaged or corroded by water ingress??


    Try a drop of WD40 in the usb socket and plug a usb lead into the socket a few times.

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘edge 705 – have i "bricked" it??’ is closed to new replies.