Blackburn Mars 3 rear not flashing

Home Forum Bike Forum Blackburn Mars 3 rear not flashing

Viewing 6 posts - 1 through 6 (of 6 total)
  • Blackburn Mars 3 rear not flashing
  • Premier Icon simmy
    Subscriber

    Just noticed today, it’s not flashing correctly just staying on permanently.

    I had a wet ride the other night and haven’t used the bike since so just wondering if the internals are wet ?

    I’ve got it the the gas fire at the moment to see if it helps.

    Any ideas ?

    Premier Icon davosaurusrex
    Subscriber

    Yeah, get a screwdriver and take the cover off. Breathe in, breathe out, left foot then right foot and repeat etc.

    cyclistm
    Member

    Internals got wet on mine, and it ended up intermittent. it did put up a reasonable fight, but didn’t last long in the wet

    Premier Icon simmy
    Subscriber

    It’s working now its dried out, not impressed with this as I’ve had a Cat Eye on the MTB that’s been fine and this is playing up after just one wet road ride.

    I’m going to have to see about putting some sealant on it or something.

    Premier Icon DezB
    Subscriber

    Lifetime warranty on Blackburn. Return, replace.

    Premier Icon davosaurusrex
    Subscriber

    Apologies for the sarcasm, I’d take the cover off, gently dab out any moisture with kitchen roll and then leave it on a tea towel on a radiator for a couple of days (assuming you have heating on the evenings now), best to dry circuit boards out slowly IME, gas fire might be a bit much.

    Anyone got a spare clip for a Mars 3? Broke mine when a ham fisted manual went wrong last week, think I’ve chipped a bit of bone off my elbow too but doubt anyone on here has a spare for that

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Blackburn Mars 3 rear not flashing’ is closed to new replies.