Avid Elixir R Problem

Home Forum Bike Forum Avid Elixir R Problem

Viewing 9 posts - 1 through 9 (of 9 total)
  • Avid Elixir R Problem
  • Premier Icon dannybgoode
    Subscriber

    Buy some Shimanos? 😉

    Cheers

    Danny B

    jambon
    Member

    That is just sooooooo funny. Ha ha ha.

    TBH that was the 1st thing that crossed my mind though.

    jambon
    Member

    Okay, what I really need is some advice rather than smug forumites suggesting that I shouldn’t have bought Avids in the first place…

    Just bled my rear brake as it was a bit spongy. During the last bit – when I’m removing air from the master cylinder and pressurising the system I could hear air being pulled in under vacuum and when I’m trying to pressurise the system I’m getting fluid pi$$ing out from the base of the lever.

    I’m guessing a seal has been dislodged/broken/was always crap.

    Any advise on pulling the lever apart and fixing it?

    Ta.

    Premier Icon dannybgoode
    Subscriber

    Just thought I’d get it in before some smug forumite did.

    I’ll shut up now as I have nothing useful to add! 🙂

    Cheers

    Danny B

    _tom_
    Member

    TBH that was the 1st thing that crossed my mind though.

    I’ve always had Avids on my mtbs and tbh I prefer them to shimano. I tried some SLX after reading all the praise they get, and found that whilst they had great stopping power, I didn’t like the lever feel or bite point and they felt very on/off. No spare parts is annoying as well.

    jambon
    Member

    So, I’ve taken it apart, re-assembled and it’s still crap so looks like a rebuild kit. Anyone know where the best place to get one is? – no LBS where I am.

    alpin
    Member

    Did you remove the air from the fluid before putting it in the system?

    torsoinalake
    Member

    Rebuild kits on eBay.

    Search for ‘Elixir lever service kit’

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Avid Elixir R Problem’ is closed to new replies.